SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |   



Category:   Application (Generic)  >   Perl Vendors:   Wall, Larry
(Red Hat Issues Fix) Perl DBI::ProxyServer Unsafe Temporary Files May Let Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1013063
SecurityTracker URL:  https://securitytracker.com/id/1013063
CVE Reference:   CVE-2005-0077   (Links to External Site)
Date:  Feb 2 2005
Impact:   Execution of arbitrary code via local system, User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in the Perl DBI library in the use of temporary files. A local user may be able to gain elevated privileges.

The 'DBI::ProxyServer' module in the Perl DBI library uses a process ID (PID) file in an unsafe manner. A local user can create a symbolic link (symlink) from a critical file on the system to the PID file used by the library. Then, when a target user invokes an application that uses the module (such as 'dbiproxy'), the symlinked file may be created or overwritten with the privileges of the target user.

The flaws reside in 'dbiproxy.PL' and 'lib/DBI/ProxyServer.pm'.

Javier Fernandez-Sanguino Pena from the Debian Security Audit Project is credited with discovering this flaw.

Impact:   A local user may be able to gain elevated privileges.
Solution:   Red Hat has released a fix.

Red Hat Enterprise Linux AS (Advanced Server) version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1AS/en/os/SRPMS/perl-DBI-1.18-3.src.rpm
b614c046679c98e6cee4b3ef143aff6e perl-DBI-1.18-3.src.rpm

i386:
22af0266ecb99d0997a2d9f245e3a048 perl-DBI-1.18-3.i386.rpm

ia64:
c77842c2d3164aaaccbdbc835b28834b perl-DBI-1.18-3.ia64.rpm

Red Hat Linux Advanced Workstation 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1AW/en/os/SRPMS/perl-DBI-1.18-3.src.rpm
b614c046679c98e6cee4b3ef143aff6e perl-DBI-1.18-3.src.rpm

ia64:
c77842c2d3164aaaccbdbc835b28834b perl-DBI-1.18-3.ia64.rpm

Red Hat Enterprise Linux ES version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1ES/en/os/SRPMS/perl-DBI-1.18-3.src.rpm
b614c046679c98e6cee4b3ef143aff6e perl-DBI-1.18-3.src.rpm

i386:
22af0266ecb99d0997a2d9f245e3a048 perl-DBI-1.18-3.i386.rpm

Red Hat Enterprise Linux WS version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1WS/en/os/SRPMS/perl-DBI-1.18-3.src.rpm
b614c046679c98e6cee4b3ef143aff6e perl-DBI-1.18-3.src.rpm

i386:
22af0266ecb99d0997a2d9f245e3a048 perl-DBI-1.18-3.i386.rpm

Red Hat Enterprise Linux AS version 3:

SRPMS:
ftp://updates.redhat.com/enterprise/3AS/en/os/SRPMS/perl-DBI-1.32-9.src.rpm
eabf3cd83dd61c9b09d2bb6e2160755a perl-DBI-1.32-9.src.rpm

i386:
6aea6d47ab2a26300af6ed577405e6b7 perl-DBI-1.32-9.i386.rpm

ia64:
9f9dbb9313e84f86908b00aeb737c424 perl-DBI-1.32-9.ia64.rpm

ppc:
ff90be122c3636ba3b2b253428092633 perl-DBI-1.32-9.ppc.rpm

s390:
fc8faf4640441c1b5cd77972a23ac4ec perl-DBI-1.32-9.s390.rpm

s390x:
371823a6fb25f64dd773073c814d513b perl-DBI-1.32-9.s390x.rpm

x86_64:
86936f627f02c8f96da5467c536997e6 perl-DBI-1.32-9.x86_64.rpm

Red Hat Desktop version 3:

SRPMS:
ftp://updates.redhat.com/enterprise/3desktop/en/os/SRPMS/perl-DBI-1.32-9.src.rpm
eabf3cd83dd61c9b09d2bb6e2160755a perl-DBI-1.32-9.src.rpm

i386:
6aea6d47ab2a26300af6ed577405e6b7 perl-DBI-1.32-9.i386.rpm

x86_64:
86936f627f02c8f96da5467c536997e6 perl-DBI-1.32-9.x86_64.rpm

Red Hat Enterprise Linux ES version 3:

SRPMS:
ftp://updates.redhat.com/enterprise/3ES/en/os/SRPMS/perl-DBI-1.32-9.src.rpm
eabf3cd83dd61c9b09d2bb6e2160755a perl-DBI-1.32-9.src.rpm

i386:
6aea6d47ab2a26300af6ed577405e6b7 perl-DBI-1.32-9.i386.rpm

ia64:
9f9dbb9313e84f86908b00aeb737c424 perl-DBI-1.32-9.ia64.rpm

x86_64:
86936f627f02c8f96da5467c536997e6 perl-DBI-1.32-9.x86_64.rpm

Red Hat Enterprise Linux WS version 3:

SRPMS:
ftp://updates.redhat.com/enterprise/3WS/en/os/SRPMS/perl-DBI-1.32-9.src.rpm
eabf3cd83dd61c9b09d2bb6e2160755a perl-DBI-1.32-9.src.rpm

i386:
6aea6d47ab2a26300af6ed577405e6b7 perl-DBI-1.32-9.i386.rpm

ia64:
9f9dbb9313e84f86908b00aeb737c424 perl-DBI-1.32-9.ia64.rpm

x86_64:
86936f627f02c8f96da5467c536997e6 perl-DBI-1.32-9.x86_64.rpm

Cause:   Access control error, State error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  2.1, 3

Message History:   This archive entry is a follow-up to the message listed below.
Jan 26 2005 Perl DBI::ProxyServer Unsafe Temporary Files May Let Local Users Gain Elevated Privileges



 Source Message Contents

Subject:  [RHSA-2005:069-01] Updated perl-DBI package fixes security issue


[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search


Content previously copyright SecurityGlobal.net LLC placed in the public domain on December 31, 2019.