SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |   



Category:   Application (Web Server/CGI)  >   Red Hat JBoss Vendors:   Red Hat
(Red Hat Issues Fix) Red Hat JBoss EAP XML Deserialization Flaw in SLF4J Component Lets Remote Users Execute Arbitrary Code on the Target System
SecurityTracker Alert ID:  1041878
SecurityTracker URL:  https://securitytracker.com/id/1041878
CVE Reference:   CVE-2018-8088   (Links to External Site)
Date:  Oct 16 2018
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): EAP 6.4, 7.1
Description:   A vulnerability was reported in Red Hat JBoss Enterprise Application Platform (EAP). A remote user can execute arbitrary code on the target system.

A remote user can send specially crafted XML data to trigger a deserialization error in the Simple Logging Facade for Java (SLF4J) EventData constructor and execute arbitrary code on the target system.

Chris McCown reported this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   Red Hat has issued a fix.

The Red Hat advisory is available at:

https://access.redhat.com/errata/RHSA-2018:2930

Vendor URL:  access.redhat.com/errata/RHSA-2018:2930 (Links to External Site)
Cause:   State error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  5, 6, 7

Message History:   This archive entry is a follow-up to the message listed below.
Apr 4 2018 Red Hat JBoss EAP XML Deserialization Flaw in SLF4J Component Lets Remote Users Execute Arbitrary Code on the Target System



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search


Content previously copyright SecurityGlobal.net LLC placed in the public domain on December 31, 2019.