SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |   



Category:   Application (Web Server/CGI)  >   Apache Tomcat Vendors:   Apache Software Foundation
(Red Hat Issues Fix) Apache Tomcat Overflow in UTF-8 Decoder Lets Remote Users Deny Service
SecurityTracker Alert ID:  1041884
SecurityTracker URL:  https://securitytracker.com/id/1041884
CVE Reference:   CVE-2018-1336   (Links to External Site)
Date:  Oct 16 2018
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 7.0.28 to 7.0.88, 8.0.0.RC1 to 8.0.51, 8.5.0 to 8.5.30, 9.0.0.M1 to 9.0.7
Description:   A vulnerability was reported in Apache Tomcat. A remote user can cause denial of service conditions on the target system.

A remote user can send specially crafted data containing supplementary characters to trigger an overflow in the UTF-8 decoder and cause the target service to enter an infinite loop.

Impact:   A remote user can cause the target service to enter an infinite loop.
Solution:   Red Hat has issued a fix.

The Red Hat advisory is available at:

https://access.redhat.com/errata/RHSA-2018:2921

Vendor URL:  access.redhat.com/errata/RHSA-2018:2921 (Links to External Site)
Cause:   Boundary error, State error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  7

Message History:   This archive entry is a follow-up to the message listed below.
Jul 26 2018 Apache Tomcat Overflow in UTF-8 Decoder Lets Remote Users Deny Service



 Source Message Contents

Subject:  [RHSA-2018:2921-01] Important: tomcat security update


[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search


Content previously copyright SecurityGlobal.net LLC placed in the public domain on December 31, 2019.