SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |   



Category:   Application (Generic)  >   curl Vendors:   curl.haxx.se
(Ubuntu Issues Fix) curl Buffer Overflow Lets Remote Users Cause the Target Service to Crash
SecurityTracker Alert ID:  1042017
SecurityTracker URL:  https://securitytracker.com/id/1042017
CVE Reference:   CVE-2018-16842   (Links to External Site)
Date:  Nov 1 2018
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in curl. A remote user can cause the target service to crash.

A remote user can send specially crafted data to trigger a buffer overflow and read back out-of-buffer data.

Brian Carpenter, Geeknik Labs, reported this vulnerability.

Impact:   A remote user can cause the target service to crash.
Solution:   Ubuntu has issued a fix.

The Ubuntu advisory is available at:

https://usn.ubuntu.com/usn/usn-3805-1

Vendor URL:  usn.ubuntu.com/usn/usn-3805-1 (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  14.04 LTS, 16.04 LTS, 18.04 LTS, 18.10

Message History:   This archive entry is a follow-up to the message listed below.
Nov 1 2018 curl Buffer Overflow Lets Remote Users Cause the Target Service to Crash



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search


Content previously copyright SecurityGlobal.net LLC placed in the public domain on December 31, 2019.